Dear reader, please download one of Myanmar unicode font and install it on your PC to see my blog well.Thanks.

Trojan distributed as 8 Ball Pool Game Hack

8 Ball Pool ဆိုတဲ့ ဘိလိယပ်ကစားတဲ့ Free Game လေးဆော့တတ်တဲ့သူများအတွက် သတင်းကောင်းပါ။

ပုံမှန်အတိုင်းမဆော့ချင်ပဲ ခုန်ပျံကျော်လွှားပြီး ဆော့ချင်တဲ့သူတွေအတွက် Cheat, Hack တွေကို အင်တာနက်မှာရှာပြီး စက်ထဲကို Download လုပ်တတ်ကြမှာပေါ့။

အခုလဲ အဲဒီအကျင့်လေးကို hacker, attacker တွေက အသုံးချပြီး မိမိစက်ထဲက Data တွေကို ခိုးယူနိုင်တဲ့ Trojan ပါတဲ့ hack tool လေးကို အွန်လိုင်းမှာ တင်ပေးထားပါတယ်။

တကယ်လို့ သင်က Download လုပ်ပြီး Tool ကို Execute လုပ်တာနဲ့ အောက်က အတိုင်း သင့် System ကို modify လုပ်ပြီး Data တွေခိုးပါလိမ့်မယ်။

- သူ့ကိုယ်သူ copy ပွားပြီး %TEMP%\ Directory ထဲကို exe file တခုအနေနဲ့ ထည့်ပါလိမ့်မယ်။ ဥပမာ chrome.exe
- စက် Reboot လုပ်လိုက်တဲ့အခါ မှာ သူ့အလိုလို startup ဖြစ်အောင် အောက်ပါအတိုင်း registry မှာ ပြင်ပါလိမ့်မယ်။
HKLM\software\microsoft\windows\currentversion\run[8ce73491bf190a3fd7028c92bd3331b1] "%TEMP%\chrome.exe"
- Windows Firewall ကို bypass လုပ်ဖို့ အောက်ပါအတိုင်း registry ကို ပြင်ပါတယ်။
HKLM\system\currentcontrolset\services\sharedaccess\parameters\firewallpolicy\standardprofile\authorizedapplications\list [%TEMP%\chrome.exe]

ပြီးတဲ့အခါ hackernople.no-ip.biz ဆီကနေ DNS query လုပ်ပါတယ်။
ပြီးတာနဲ့ စက်ထဲကနေ desktop's screenshot, current date, computer name, username, operating system နဲ့ လက်ရှိသုံးနေတဲ့ IP address တွေကို CoC Server ဆီကို ပို့တော့တာပဲ။
ဒီ Trojan က စက်ထဲက File တွေကိုလဲ ဖျက်ပစ်နိုင်ပါသေးတယ်။ ပြီးတော့ "WebBrowserPassView" လိုမျိုး Password Recovery Tool တွေကိုလဲ ကိုယ်မသိအောင် Download & Install လုပ်ပါသေးတယ်။

ဒီတော့ကာ...ဒီ Trojan ရဲ့ အန္တရာယ်ဟာ သူ့ရဲ့ ခိုးယူနိုင်၊ ဖျက်ဆီးနိုင်တဲ့ Data ရဲ့ အရေးကြီးမှုပမာဏပေါ်မူတည်ပါတယ်။

ဒါကို ရှာဖွေတွေ့ရှိတာကတော့ Dell SonicWall Security Center ကပါ။

Dell SonicWall Gateway AntiVirus တွေကိုတော့ Signature update လုပ်ထားဖို့လိုပါတယ်။

သင့် network မှာ Dell မဟုတ်တဲ့ တခြား security device တွေ သုံးရင်တော့ အမြန်ဆုံး signature update လုပ်ဖို့တိုက်တွန်းပါတယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)


Route Redistribution 101 (4)


အခုမှ ဖတ်မယ့်သူတွေ အနေနဲ့ အရင် ပို့စ် Route Redistribution 101 (1) , Route Redistribution 101
(2) နဲ့ Route Redistribution 101 (3) အကို အရင်ဖတ်ပါ။
အောက်က Topology သုံးပြီး IP Address, RIP , OSPF တွေ Configure လုပ်ပါမယ်။ အောက်မှာ Redistribution မလုပ်ရသေးတဲ့ Routing Configuration တွေကို နမူနာကြည့်နိုင်ပါတယ်။
R1#show run | section rip
router rip
 version 2
 offset-list 0 out 5 (ဒါက ဒီပို့စ်ရဲ့ အဓိက ပြဿနာကို ဖန်တီးချင်လို့ hop count 6 ရအောင် လုပ်ယူထားတာပါ။)
 network 1.0.0.0
 network 192.168.12.0
 no auto-summary

R2#show run | section rip
router rip
 version 2
 network 192.168.12.0
 network 192.168.23.0
 network 192.168.24.0
 no auto-summary

R3#show run | section rip
router rip
 version 2
 network 192.168.23.0
 no auto-summary

R4#show run | section rip
router rip
 version 2
 network 192.168.24.0
 no auto-summary

R3#show run | section ospf
router ospf 1
 log-adjacency-changes
 network 192.168.34.0 0.0.0.255 area 0

R4#show run | section ospf
router ospf 1
 log-adjacency-changes
 network 192.168.34.0 0.0.0.255 area 0

ပြီးတဲ့အခါ Router 2,3 နဲ့ 4 တလုံးချင်းစီရဲ့ RIP Routing Table တွေကို ကြည့်ပါမယ်။

R2#show ip route rip
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/6] via 192.168.12.1, 00:00:13, FastEthernet1/0

R3#show ip route rip
R    192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:25, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/7] via 192.168.23.2, 00:00:25, FastEthernet0/0
R    192.168.24.0/24 [120/1] via 192.168.23.2, 00:00:25, FastEthernet0/0

R4#show ip route rip
R    192.168.12.0/24 [120/1] via 192.168.24.2, 00:00:04, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/7] via 192.168.24.2, 00:00:04, FastEthernet0/0
R    192.168.23.0/24 [120/1] via 192.168.24.2, 00:00:04, FastEthernet0/0
R2 က R1 ရဲ့ loopback network 1.1.1.0/24 ကို configure လုပ်ထားတဲ့ အတိုင်း hop count 6 နဲ့ learn လုပ်ထားတာကလွဲလို့ ကျန်တာတွေ အားလုံး ပုံမှန်ပါပဲ။

R3#show ip route ospf
R4#show ip route ospf

R3 နဲ့ R4 က directly connected link တွေမှာပဲ OSPF ကို run ထားလို့ OSPF Route တွေကို လောလောဆယ်မတွေ့ရသေးပါဘူး။
အခု RIP ကနေ OSPF ကို Route Redistribution စ လုပ်ပါမယ်။

R3(config)#router ospf 1
R3(config-router)#redistribute rip subnets
R4(config)#router ospf 1
R4(config-router)#redistribute rip subnets

R3#show ip route ospf
O E2 192.168.24.0/24 [110/20] via 192.168.34.4, 00:02:32, FastEthernet1/0
R1 ဟာ အရင်က 192.168.24.0 ကို R2 က တဆင့် Learn လုပ်ပါတယ်။
အခု Redistribution လုပ်ပြီးတဲ့အခါ R4 ကနေ တဆင့် learn လုပ်ပါတယ်။ OSPF AD က OSPF ထက်ပိုကောင်းလို့ပါ။
R4 ရဲ့ OSPF Route ကိုကြည့်ရအောင်။

R4#show ip route ospf
O E2 192.168.12.0/24 [110/20] via 192.168.34.3, 00:07:33, FastEthernet1/0
     1.0.0.0/24 is subnetted, 1 subnets
O E2    1.1.1.0 [110/20] via 192.168.34.3, 00:07:33, FastEthernet1/0
O E2 192.168.23.0/24 [110/20] via 192.168.34.3, 00:07:33, FastEthernet1/0

အရင် Redistribution မလုပ်ခင်က R4 ဟာ 192.168.12.0/24, 1.1.1.0/24 network တွေကို သွားဖို့ next hop က R2 ပါ။ အခု Redistribute လုပ်ပြီးတဲ့အခါ next hop က R3 ဖြစ်သွားပါတယ်။
ဒါကို sub-optimal routing လို့ခေါ်ပါတယ်။
ဒီပို့စ်မှာ ပြောချင်တာက redistribution metric problem ဖြစ်တဲ့အတွက် AD ကြောင့်ဖြစ်တဲ့ ဖြစ်တဲ့ ပြဿနာကို ခဏ ကျော်သွားပါမယ်။
လောလောဆယ် sub-optimal routing ကို ခဏမေ့ထားပြီး ဆက်သွားပါမယ်။
OSPF ကို RIP ထဲကို redistribute လုပ်ပါမယ်။
R3(config)#router rip
R3(config-router)#redistribute ospf 1 metric 1
R4(config)#router rip
R4(config-router)#redistribute ospf 1 metric 1
ပြီးတဲ့အခါ R2 ရဲ့ RIP Route ကို ပြန်ကြည့်ကြည့်ပါ။

R2#show ip route rip
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/1] via 192.168.24.4, 00:00:15, FastEthernet2/0
R    192.168.34.0/24 [120/1] via 192.168.24.4, 00:00:15, FastEthernet2/0
                     [120/1] via 192.168.23.3, 00:00:18, FastEthernet0/0
Redistribute မလုပ်ခင်က 1.1.1.0 ရဲ့ next hop က R1 ဖြစ်ပေမယ့် Redistribute လုပ်လိုက်တဲ့အခါ next hop က R4 ဖြစ်သွားတာကိုတွေ့ပါမယ်။ ဒီမှာ ပြဿနာစ ပါပြီ။
1.1.1.1  ရဲ့ route ကို R2 ကနေ trace ကြည့်လိုက်ပါ။

R2#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1

  1 192.168.24.4 680 msec 176 msec 364 msec
  2 192.168.34.3 20 msec 20 msec 24 msec
  3 192.168.23.2 20 msec 32 msec 28 msec
  4 192.168.24.4 52 msec 72 msec 24 msec
  5 192.168.34.3 28 msec 44 msec 40 msec
  6 192.168.23.2 44 msec 48 msec 40 msec
  7 192.168.24.4 60 msec 60 msec 80 msec
  8 192.168.34.3 88 msec 60 msec 72 msec
  9 192.168.23.2 80 msec 60 msec 60 msec
 10 192.168.24.4 80 msec 108 msec 44 msec

Routing Loop ဖြစ်နေပါပြီ။
Loop ဖြစ်ရခြင်းအကြောင်းကတော့ R2 က 1.1.1.0/24 network ရဲ့ routing update ကို interface ၂ ခုကနေ ရနေလို့ပါ။ R1 ကနေ hop count 6 နဲ့ ရတယ်။ R3 ကနေ hop count 1 နဲ့ ရတယ်။
R2 က lowest hop count ကို ရွေးပြီး next hop အဖြစ် R3 ကို ရွေးလိုက်တယ်။ ဒါပါပဲ။
RIP က OSPF , EIGRP တို့လို Internal, External Route တွေ ကို ခွဲမမြင်နိုင်တဲ့အတွက် lowest metric ကိုရွေးလိုက်တာပါပဲ။
ဒီပြဿနာကို မရှင်းခင်မှာ Redistribution ရဲ့ Rule ကို နည်းနည်းရှင်းပြအုံးမယ်။
R2 မှာ ဖြစ်နေတဲ့ Metric ပြဿနာက တကယ်တော့ 1.1.1.0/24 network ကို ကျတော်တို့ RIP ကနေ OSPF ကို Redistribute လုပ်တယ်၊ နောက်တခါ OSPF ကနေ RIP ကို Redistribute လုပ်တာကနေ ဖြစ်လာတာပါ။
ဒီတော့ မှတ်ထားလိုက်ပါ။
Route Redistribution လုပ်တဲ့အခါ Routing Protocol X ကနေ Y ကို Redistribute လုပ်ပြီး Y ကနေ X ကို ပြန် Redistribute မလုပ်ရပေါ့ဗျာ။ ဘိုလိုပြောရမယ်ဆိုရင် “Redistribution Rule: Never advertise prefixes from routing protocol X into Y and then back into X.”
ကဲ…. အပေါ်က looping ပြဿနာကို ရှင်းကြစို့ဗျာ။
ရှင်းနည်း အများကြီးရှိတယ်ဗျ။ ဒီမှာတော့ ကျတော် Access-list နဲ့ ပဲ ရှင်းပြတော့မယ်ဗျာ။ ပို့စ် တော်တော်ရှည်နေလို့။
R3 နဲ့ R4 မှာ access-list ကို အောက်ကလို configure လုပ်လိုက်မယ်။

R3#(config)#ip access-list standard NATIVE_OSPF_ROUTES
R3#(config-std-nacl)#permit 192.168.34.0 0.0.0.255
R3#(config)#route-map NATIVE_OSPF permit 10
R3#(config-route-map)#match ip address NATIVE_OSPF_ROUTES
R3#(config-route-map)#route-map NATIVE_OSPF deny 20
R3#(config)#router rip
R3#(config-router)#redistribute ospf 1 metric 1 route-map NATIVE_OSPF

R4#(config)#ip access-list standard NATIVE_OSPF_ROUTES
R4#(config-std-nacl)#permit 192.168.34.0 0.0.0.255
R4#(config)#route-map NATIVE_OSPF permit 10
R4#(config-route-map)#match ip address NATIVE_OSPF_ROUTES
R4#(config-route-map)#route-map NATIVE_OSPF deny 20
R4#(config)#router rip
R4#(config-router)#redistribute ospf 1 metric 1 route-map NATIVE_OSPF

ပြီးတာနဲ့ R2 ရဲ့ Routing Table ကို ကြည့်လိုက်ပါ။ 1.1.1.0/24 network ရဲ့ next hop က R1 ပြန်ဖြစ်သွားတာကိုတွေ့ရပါမယ်။

R2#sh ip route rip
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/6] via 192.168.12.1, 00:00:14, FastEthernet1/0

Traceroute လုပ်ကြည့်တဲ့အခါ လဲ looping ဖြစ်မနေတော့တာကို တွေ့ရပါလိ့မ်မယ်။

R2#traceroute 1.1.1.1
Type escape sequence to abort.
Tracing the route to 1.1.1.1
  1 192.168.12.1 64 msec 24 msec 16 msec
R2#

ကဲ…ပြဿနာပြေလည်သွားပါပြီ။ ဒါပေမယ့် ဒီနည်းလမ်းဟာ scalable တော့ မဖြစ်ပါဘူး။ တကယ်လို့ OSPF မှာ network prefix ထပ်တိုးလာခဲ့ရင် access-list မှာ ထပ်မံ ပြင်ဆင်ရမှာဖြစ်လို့ပါ။
ဒါပေမယ့် 101 ဆိုတဲ့အတိုင်း အခြေခံ လောက်သိစေချင်တဲ့အတွက် ဒီလောက်နဲ့ ပဲ ရပ်ပါတော့မယ်။
Administrative Distance Problem ဆိုတာ ရှိပါသေးတယ်။ ဒါပေမယ့် ဆက်မရေးတော့ပါဘူး။ AD တန်ဖိုးတွေကို adjust လုပ်ပြီးရှင်းတာကို ပြောတာပါပဲ။
Route Redistribution ကို အခြေခံလောက်နားလည်သွားပြီး Advance ပိုင်းများလေ့လာနိုင်ပါစေဗျာ။

တကယ်တော့ ဒီလိုစာတွေရေးရတာတော်တော်ကို အချိန်ပေးရတယ်ဗျ။ တခါတခါကျတော့လဲ စာရေးမယ့်အစား Video Tutorial တွေပဲ လုပ်ပစ်ချင်စိတ်ပေါက်လာတယ်။ သို့ပေမယ့် မြန်မာပြည်အင်တာနက်အကြောင်းကို သိလေတော့ Video ထက် စာတွေက လောလောဆယ် ပိုအဆင်ပြေမယ်လို့ ထင်လို့ စာအရှည်ကြီးတွေကို အချိန်ပေးပြီးရေးရတာပါ။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)


Route Redistribution 101 (3)

အခုမှ စဖတ်မယ့်သူတွေအတွက် အရင်ပို့စ် (၂) ခု Route Redistribution 101 (1) နှင့် Route Redistribution 101 (2) ကို အရင်ဖတ်ပါ။
ဒီတခါ OSPF နဲ့ RIP ကို အောက်က Topology ကိုသုံးပြီး Redistribute လုပ်ကြည့်ပါမယ်။


IP Address တွေ ကို သက်ဆိုင်ရာ Interface တွေမှာ Configure လုပ်ပြီးတဲ့အခါ OSPF နဲ့ RIP တွေကို အောက်ပါအတိုင်း Configure လုပ်ပါမယ်။

R1(config)#router ospf 1
R1(config-router)#network 1.1.1.0 0.0.0.255 area 0
R1(config-router)#network 192.168.12.0 0.0.0.255 area 0

R2(config)#router ospf 1
R2(config-router)#network 192.168.12.0 0.0.0.255 area 0

R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.23.0

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 3.3.3.0
R3(config-router)#network 192.168.23.0

ဒီအဆင့်ထိ ဘာမှ မလုပ်ရသေးပါဘူး။ Routing Table အသီးသီးကိုကြည့်ပါမယ်။

R1#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet1/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0

R2#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet1/0
     3.0.0.0/24 is subnetted, 1 subnets
R       3.3.3.0 [120/1] via 192.168.23.3, 00:00:12, FastEthernet2/0
C    192.168.23.0/24 is directly connected, FastEthernet2/0

R3#show ip route
Gateway of last resort is not set
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
C    192.168.23.0/24 is directly connected, FastEthernet2/0

အခု Redistribution ကို Configure လုပ်ပါမယ်။
ရှေ့မှာ ပြောခဲ့သလို Redistribution ဟာ Outbound မှာပဲ အလုပ်လုပ်တဲ့အတွက် OSPF, RIP တို့အတွက် Outbound ဖြစ်တဲ့ R2 မှာ Configure လုပ်ပါမယ်။

ပထမဆုံး OSPF ကို RIP ထဲကို Redistribute လုပ်ပါမယ်။

R2(config)#router rip
R2(config-router)#redistribute ospf 1 metric 5

ပြီးတာနဲ့ R3 ရဲ့ Routing Table ကို ကြည့်ပါမယ်။

R3#show ip route
Gateway of last resort is not set
R    192.168.12.0/24 [120/5] via 192.168.23.2, 00:00:05, FastEthernet2/0
     1.0.0.0/32 is subnetted, 1 subnets
R       1.1.1.1 [120/5] via 192.168.23.2, 00:00:05, FastEthernet2/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
C    192.168.23.0/24 is directly connected, FastEthernet2/0

RIP ထဲကို OSPF Network တွေ ရောက်နေတာကိုတွေ့ရပါပြီ။

အခုတခါ RIP ကို OSPF ထဲကို Redistribute လုပ်ပါမယ်။

R2(config)#router ospf 1
R2(config-router)#redistribute rip subnets

ဒီနေရာမှာ subnets ဆိုတဲ့ command ကို မသုံးရင် OSPF Routing Information တွေဟာ Classful အနေနဲ့ Redistribute လုပ်လိုက်မှာပါ။
Classless အနေနဲ့ Redistribute လုပ်စေချင်လို့ subnets command ကို သုံးရခြင်းဖြစ်ပါတယ်။
နောက်တခုက metric ကို သက်သက် advertise မလုပ်ပဲ default metric ကိုပဲ သုံးလိုက်ပါတယ်။ မှတ်မိသေးလားမသိဘူး ပထမဆုံးပို့စ်မှာ ကျတော် Default Seed Metric တွေကို ရှင်းပြခဲ့ပါတယ်။
ဒါကြောင့် R1 ရဲ့ Routing Table ကို ကြည့်တဲ့အခါ redistribute metric ဟာ 20 ဖြစ်နေတာကိုတွေ့ရပါမယ်။

R1 ရဲ့ Routing Table ကို ကြည့်ရအောင်

R1#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet1/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
O E2    3.3.3.0 [110/20] via 192.168.12.2, 00:01:50, FastEthernet1/0
O E2 192.168.23.0/24 [110/20] via 192.168.12.2, 00:01:50, FastEthernet1/0

RIP ကနေ Redistribute လုပ်လိုက်တဲ့ Routing Information တွေကို OSPF External Type 2 Route တွေ အနေနဲ့ မြင်ရပါပြီ။
Metric Type 1 နဲ့ Type 2 ဆိုပြီးရှိရာမှာ ဘာတွေ ကွာလဲ ဆိုတော့
Route တွေကို OSPF ထဲကို Type 1 အနေနဲ့ Redistribute လုပ်တဲ့အခါ External Network ကိုရောက်ဖို့ Cost တန်ဖိုး တွေဟာ Router တလုံးကို ဖြတ်သွားတိုင်း ပြောင်းလဲသွားနိုင်ပါတယ်။
Type 2 အနေနဲ့ Redistribute လုပ်မယ်ဆိုရင်တော့ OSPF domain ထဲမှာရှိတဲ့ Router တွေဟာ External Network ကိုရောက်ဖို့ Cost တန်ဖိုးတွေ ကို အတူတူအနေနဲ့ပဲ သိပါတယ်။
ကဲ…ဒီလောက်ဆိုရင် OSPF/RIP Route Redistribution ကို အခြေခံအနေနဲ့ နားလည်လောက်ပြီလို့ ထင်ပါတယ်။ နားမလည်ခဲ့ရင်တော့ ကျတော့် ရှင်းပြချက်တွေမှာ လိုအပ်ချက်တွေရှိခဲ့လို့ ကြိုတင်တောင်းပန်ပါရစေ။
Route Redistribution ဟာ Configuration လုပ်တဲ့ command က လွယ်ပါတယ်။ ဒါပေမယ့် သူ့ကို နားလည်ဖို့ကတော့ နည်းနည်းခက်ခဲပါတယ်။ နောက်ပြီး သူ့မှာလဲ သတိထားရမယ့် ပြဿနာ တချို့ ရှိပါသေးတယ်။
နောက်ပိုစ့်မှာ ဆက်ပါမယ်။
ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)


Allowing WeChat to Sign Up and to get QR Code for login in SonicWall

SonicWall Firewall Application Control က WeChat Application အတွက် လိုအပ်တဲ့ Application တချို့ကို Application Control ကနေ Block ထားပါတယ်။

အဲဒီအတွက်ကြောင့်ပဲ Mobile Device တွေကနေ WeChat ကို Sign Up လုပ်တဲ့အခါ "Connection error. Check your network settings." ဆိုတာပေါ်ပြီး Account Create လုပ်မရပါဘူး။



Account ရှိပြီးသား Device တွေဆိုရင်လဲ QR Code ကို Scan လုပ်ပြီး Sign in လုပ်မရပါဘူး။

Laptop တွေ Desktop တွေမှာဆိုရင်လဲ QR Code ကို Load လုပ်လို့မရပဲ အောက်ကလို Error ပဲ ပေါ်ပါတယ်။



ဒါကို ရှင်းမယ်ဆိုရင် SonicWall ရဲ့ Application Control က block ထားတဲ့ အောက်က Application Signature List ကို Unblock/Allow လုပ်ရပါမယ်။

Application Category : Proxy-Access (27)
Application : Proxy-Access HTTP (966)
Application Signature : Proxy-Access HTTP Proxy -- HTTP Proxy POST (9685)

အောက်က IP Address List ကို Allow/Exclude from Application Control List ထဲမှာ ထည့်ပေးရပါမယ်။ (တကယ်တော့ WeChat က သုံးထားတဲ့ IP Address တွေအများရှိပါသေးတယ်။ အခု ပြထားတာနဲ့တင်အဆင်ပြေလို့ ထပ်မထည့်တော့တာပါ။ ဒီ List နဲ့ အဆင်မပြေသေးရင်တော့ Log မှာ ဝင်စစ်ပြီး ထပ်ထည့်ပေါ့ဗျာ။)
203.205.129.101
203.205.147.168
203.205.151.160
140.206.160.213

အားလုံး Unblock/Allow လုပ်ပြီးပြီဆိုရင်တော့ Network ထဲက User တွေ WeChat ကို အတားအဆီးမရှိ အဆင်ပြေပြေသုံးနိုင်ပါပြီ။
(ကျတော်ကတော့ QQ က တဆင့် ပေါက်ဖွားလာတဲ့ ဒီ တရုတ် Application ကို လုံခြုံရေးအရ စိတ်မချလို့မဖွင့်ချင်ပါဘူး။ ဒါပေမယ့် အလုပ်လိုအပ်ချက်အရဖွင့်​ပေးရတော့လဲ သေချာစောင့်ကြည့်ပေတော့ပေါ့။)

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Best practices for avoiding email scams

နှစ်ကုန်နားနီးလာတဲ့အခါ ထုံးစံအတိုင်း online shopping site တွေက ThanksGiving Day, Black Friday, Cyber Monday, Christmas, New Year Promotion စသည်ဖြင့် Discount တွေအပြိုင်အဆိုင်လုပ်လာပါပြီ။
ဝယ်သူတွေကလဲ ဒါမျိုးဆိုအကြိုက်ပေါ့။
ဒီအချိန်မှာ online shopper တွေကို ပစ်မှတ်ထားတဲ့ spammer, attacker, hacker တွေကလဲ spam campaign တွေကို ဝမ်းပန်းတသာ အားကြိုးမာန်တက်လုပ်လာလေ့ရှိပါတယ်။

Network , System နဲ့ Email Security ပိုင်းတွေ သိပ်မကောင်းတဲ့ Network တွေဟာဆိုရင် အဓိက ပစ်မှတ်ဖြစ်ခံရတတ်လေ့ရှိပါတယ်။
Security ကောင်းတွေရှိလဲ အတွေ့အကြုံပိုင်းအားနည်းသေးရင် လုံခြုံရေးကျိုးပေါက်လေ့ရှိပါတယ်။
ဒီတော့ မိမိ Network ထဲက User တွေကို Educate လုပ်ဖို့လိုပါတယ်။
အောက်ပါ အချက်တွေက ယေဘုယျအားဖြင့် တိုက်ခိုက်ခံရမှုမှ အနည်းဆုံးဖြစ်အောင် ကာကွယ်ပေးနိုင်တဲ့ အချက်တွေပါပဲ။ တနည်းအားဖြင့် Best Practices တွေပေါ့ဗျာ။

- Email ထဲမှာ ပါလာတဲ့ Link တွေကို မိမိသေချာမသိပဲ Click လုပ်ခြင်းမလုပ်ပါနဲ့။
- မိမိကို Email ပို့တဲ့ Sender ကို Trusted Sender ဟုတ်မဟုတ် Authenticate and Verify လုပ်ပါ။
- Sender ရဲ့ Email Address က Domain name နဲ့ Email Body မှာပါတဲ့ Link တွေကို Verify လုပ်ပါ။
- တချို့ Email Address ရဲ့ Domain name တွေက သံသယရှိစရာကောင်းပါတယ်။ ဥပမာ customer_service@amazon.com--0123-xyz.malicious-site.com ဆိုရင် malicious-site.com ဆိုတာ amazon က ပိုင်တဲ့ Domain လား ဒါမှမဟုတ် တခြားအဖွဲ့အစည်း/တစုံတယောက်က ပိုင်တာလား။
(ဒါမျိုး သံသယဖြစ်ရင် အကောင်းဆုံးက Amazon Website ကိုသွားပြီး customer service ရဲ့ email ကို ဖြစ်စေ online support နဲ့ ဖြစ်စေ verify လုပ်တာ အကောင်းဆုံးပါပဲ။)
- Email Address ရဲ့ domain name နဲ့ Email body ထဲမှာပါတဲ့ Link ရဲ့ Domain name ကို ပုံမှန်အတိုင်း Verify မလုပ်နိုင်ခဲ့ရင် Browser တခုခုကိုဖွင့်ပြီး ယင်း domain name များကို ရိုက်ထည့်ကာ ပေါ်လာတဲ့ Website ကို ကြည့်ပြီး မိမိ ယုံကြည်ရတဲ့ Website ဟုတ်မဟုတ် စစ်ဆေးနိုင်ပါသေးတယ်။
- တကယ်လို့ Verify မလုပ်ချင်ဘူး၊ သံသယလဲ ရှိနေတယ်ဆိုရင် IT အဖွဲ့ ကို စစ်ဆေးပေးဖို့သာ အကြောင်းကြားပါ။
- ကိုယ်မသိတဲ့ သူ/အဖွဲ့အစည်းဆီကလာတဲ့ Email ထဲက Link နဲ့ Attachment တွေကို မဖွင့်ပါနဲ့။
- မိမိ Computing Device ရဲ့ Operating System, Install လုပ်ထားတဲ့ Web Browser နဲ့ Software တွေကို အမြဲတမ်း up-to-date ဖြစ်နေပါစေ။
- Host-based , Network-based Gateway Anti-Virus နဲ့ Intrusion Detection System တွေကို install လုပ်ပါ။ အမြဲတမ်း Up-to-date  ဖြစ်နေပါစေ။

ဒီအပေါ်က အချက်တွေဟာ User ကို Educate လုပ်ဖို့နဲ့ တချို့ အချက်တွေက IT Team members တွေ လိုက်နာရမယ့် အချက်တွေပဲ ဖြစ်ပါတယ်။

Spammer , Attacker, Hacker ရန်များမှ ကင်းဝေးပါစေ။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Route Redistribution 101 (2)

ပြီးခဲ့တဲ့ ပို့စ် http://www.ictformyanmar.com/2015/12/route-redistribution-101.html မှာ Route Redistribution အကြောင်း အစပျိုးခဲ့ပါတယ်။
ခု ဆက်လေ့လာကြတာပေါ့....

Route Redistribution က သူ့အလိုလို အလုပ်မလုပ်ဘူးဗျ...
ဟုတ်မဟုတ် အောက်က Topology ကိုသုံးပြီး Router ၃ လုံးကို Configure လုပ်ကြည့်ရအောင်


အောက်က အတိုင်း R1, R2, R3 တွေမှာ Configure လုပ်မယ်

R1(config)#router eigrp 12
R1(config-router)#no auto-summary
R1(config-router)#network 192.168.12.0
R1(config-router)#network 1.1.1.0 0.0.0.255
R1(config-router)#

R2(config)#router eigrp 12
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.12.0
R2(config-router)#exit
R2(config)#
R2(config)#router rip
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.23.0
R2(config-router)#

R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#no auto-summary
R3(config-router)#network 192.168.23.0
R3(config-router)#network 3.3.3.0
R3(config-router)#

ကဲ EIGRP, RIP တွေကို သက်ဆိုင်ရာ Router တွေမှာ Configure လုပ်ပြီးပြီ။
Route တွေကြည့်ရအောင်

R1#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0


R2#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/156160] via 192.168.12.1, 00:01:07, FastEthernet0/0
C    192.168.23.0/24 is directly connected, FastEthernet1/0

R3#show ip route

Gateway of last resort is not set
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
C    192.168.23.0/24 is directly connected, FastEthernet1/0

ကဲ... R2 က R1 နဲ့ R3 ရဲ့ loopback တွေကို သိတယ် ဒါပေမယ့် R1 က R3 ရဲ့ Route ကိုမသိသလို R3 က လဲ R1 ရဲ့ Route ကိုမသိပါဘူး။
ဘာလို့လဲဆိုတော့ R2 က Redistribute မလုပ်လို့ပါပဲ။

ဒါကြောင့် Route Redistribution ဆိုတာ ကို လိုအပ်လာတာပါ။

ကဲ Route Redistribution ကို R2 မှာ Configure လုပ်ကြည့်မယ်။
RIP ကို EIGRP ထဲကို Redistribute လုပ်ပါမယ်။
R2(config-router)#router eigrp 12
R2(config-router)#redistribute rip metric 1500 100 255 1 1500   (RIP ကနေ EIGRP ကို Redistribute လုပ်တဲ့အခါ Metric ကို EIGRP က နားလည်တဲ့ K Value တွေနဲ့ ထည့်ပေးရမယ်ဆိုတာတော့ သိရပါမယ်။)

EIGRP ကို RIP ထဲကို Redistribute လုပ်ပါမယ်။
R2(config)#router rip
R2(config-router)#redistribute eigrp 12 metric 10 (RIP ရဲ့ Metric က hop count ဆိုတာကိုလည်း သိကြမှာပါ။)

ပြီးတာနဲ့ R1 နဲ့ R3 ရဲ့ Routing Table ကို ပြန်ကြည့်လိုက်ပါ။ Redistributed Route တွေကို မြင်ရမှာ ဖြစ်ပါတယ်။
R1#show ip route
Gateway of last resort is not set
C    192.168.12.0/24 is directly connected, FastEthernet0/0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
D EX    3.3.3.0 [170/1734656] via 192.168.12.2, 00:03:17, FastEthernet0/0
D EX 192.168.23.0/24 [170/1734656] via 192.168.12.2, 00:03:17, FastEthernet0/0


R3#show ip route
Gateway of last resort is not set
R    192.168.12.0/24 [120/10] via 192.168.23.2, 00:00:26, FastEthernet1/0
     1.0.0.0/24 is subnetted, 1 subnets
R       1.1.1.0 [120/10] via 192.168.23.2, 00:00:26, FastEthernet1/0
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
C    192.168.23.0/24 is directly connected, FastEthernet1/0

ကဲ...ဒီလောက်ဆို EIGRP to/from RIP Route Redistribution ကို နည်းနည်း မြင်လာပြီလို့ထင်ပါတယ်။
နောက်ပို့စ်မှာ OSPF နဲ့ RIP အပြန်အလှန် Redistribute လုပ်တာကို ပြပါအုံးမယ်။

Routing Table တွေကို ပြတဲ့အခါမှာ နေရာ ပိုထွက်လာအောင် မလိုတာတွေ ကျတော် ဖြုတ်ထားပါတယ်။ နားလည်မယ်လို့ထင်ပါတယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Route Redistribution 101 (1)

Redistribution အကြောင်းနည်းနည်းပွားပါရစေ။
မဖတ်ခင် Routing Protocols တွေအကြောင်းတော့ သိထားဖို့လိုပါတယ်။
ကဲ...စလိုက်ရအောင်။
မတူညီတဲ့ Routing Protocols တွေ အချင်းချင်း Routing Information တွေကို Exchange လုပ်တာကို Redistribution လုပ်တယ်လို့ခေါ်ပါတယ်။
Static Route တွေနဲ့ Directly Connected Route တွေကိုလဲ Restribute လုပ်လို့ရပါသေးတယ်။
အောက်ကပုံမှာနမူနာကြည့်ပါ။



EIGRP, OSPF နဲ့ RIP ဆိုပြီး Network သုံးမျိုးကို ချိတ်ထားပါတယ်။
သူတို့ တခုကနေ တခုကို routing information တွေ exchange လုပ်ဖို့ Redistribution လိုပါတယ်။

Redistribution ကို Outbound မှာပဲ လုပ်လို့ရပါတယ်။
အောက်ကပုံကိုကြည့်ပါ။



EIGRP ရဲ့ Routing Information ကို RIP ကို Redistribute လုပ်ဖို့ R2 မှာပဲ လုပ်လို့ရမှာပါ။
RIP ရဲ့ Routing Information ကို EIGRP ကို Redistribute လုပ်ဖို့ဆိုရင်လဲ R2 မှာပဲ လုပ်လို့ရမှာပါ။

Routing Protocol တခုကနေ နောက်တခုကို Redistribute လုပ်တဲ့အခါ မတူညီတဲ့ Seed Metric ဆိုတာကို သုံးရပါတယ်။
Metric တွေကလဲ Routing Protocol တခုနှင့်တခု မတူပါဘူး။
RIP မှာ ဆိုရင် Hop count ၊ EIGRP မှာဆိုရင် K-Values (Bandwidth, Delay, Load and Reliability) သုံးပြီး၊
OSPF မှာတော့ Cost ကိုသုံးပါတယ်။

နောက်တချက်က Routing Protocol တခုကနေ နောက်တခုရဲ့ Metric ကို Redistribute လုပ်ဖို့ convert လုပ်ဖို့လိုပါသေးတယ်။

မဖြစ်မနေသိထားရမယ့် Default Seed Metric တွေကတော့ ဒါတွေပါပဲ။



Protocol Default Seed Metric
RIP Infinity
EIGRP Infinity
OSPF 20 except BGP is 1.
BGP BGP metric is set to IGP metric


ဒီလောက်ပါပဲ။ နည်းနည်းနားလည်ရခက်မယ်၊ မရှင်းမရှင်းဖြစ်နေမယ်လို့ ထင်ပါတယ်။ သည်းခံပါ။

Redistribution ကို ဘယ်လိုလုပ်ရတယ်ဆိုတာကိုနောက်ပို့စ်မှာ ရေးပါမယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Microsoft Word Remote Code Execution Vulnerability (CVE-2015-0097)

Microsoft Office Sotfware တွေမှာ Remote code execution vulnerability ရှိပါတယ်။
ဒီအားနည်းချက်ကို Attacker တွေက အခွင့်ကောင်းယူပြီး အသုံးချနိုင်ပါတယ်။
ဘယ်လိုအသုံးချလဲဆိုတော့ ပြုပြင်ထားတဲ့ Microsoft Word, Excel or Powerpoint File တခုကို email က ဖြစ်စေ၊ တခြားနည်းလမ်းတခုခုနဲ့ဖြစ်စေ Download လုပ်စေပြီး
User ကို ဖွင့်ကြည့်စေပါတယ်။
User ဖွင့်ကြည့်လိုက်ပြီဆိုတာနဲ့ File ထဲမှာ embed လုပ်ထားတဲ့ code က run ပါပြီ။
Run ပြီးတာနဲ့ code က ဖန်တီးထားတဲ့ Attacker ရဲ့ Server ကို ချိတ်ပြီး .hta ဖိုင်တခုကို Download လုပ်ပြီး
Windows ရဲ့ \appdata\roaming\microsoft\windows\start menu\programs\startup directory ထဲကို သွားထည့်ပါတယ်။

ကဲ ဒီဖိုင် စက်ထဲရောက်ပြီဆိုတာနဲ့ Attacker က Remote ကနေ သူလုပ်ချင်တာကို လုပ်နိုင်ပြီပေါ့ဗျာ။

Machine ကို reboot/restart လုပ်လဲ startup အနေနဲ့ run နေမှာပဲဖြစ်ပါတယ်။

ဒီတော့ သင့်အနေနဲ့ Security Devices တွေရဲ့ Signature တွေကို update ဖြစ်နေလားဆိုတာ စစ်ဖို့ လိုပါတယ်။

CVE-2015-0097 အကြောင်း အသေးစိတ် သိချင်ရင်တော့ အောက်က လင့်မှာ သွားဖတ်နိုင်ပါတယ်။

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-0097

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

NTP Daemon Vulnerabilities

Linux Based NTP Server သုံးတဲ့ System/Network သမားတွေအနေနဲ့ နောက်ဆုံး Version ကို အမြန်ဆုံး Update လုပ်ဖို့လိုပါပြီ။

လွန်ခဲ့တဲ့ ရက်အနည်းငယ်က Dell SonicWall Security Center က နေ အောက်ပါ NTP Daemon Vulnerabilities တွေကို တွေ့ရှိထားပါတယ်။

- "NTP Daemon Arbitrary File Overwrite", which addresses CVE-2015-7703
အသေးစိတ်ကို ဒီလင့်မှာ သွားဖတ်ပါ။ http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7703
- "NTP Daemon Assertion Failure DoS", which addresses CVE-2015-7855
အသေးစိတ်ကို ဒီလင့်မှာ သွားဖတ်ပါ။ http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7855
- "NTP Daemon Crypto-NAK Authentication Bypass 1" and "NTP Daemon Crypto-NAK Authentication Bypass 2", which address CVE-2015-7871
အသေးစိတ်ကို ဒီလင့်မှာ သွားဖတ်ပါ။ http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-7871

အရေးအကြီးဆုံး က crypto-NAK bug ပါပဲ။
လွန်ခဲ့တဲ့ ၂ ပတ် ၃ ပတ်ခန့် က NTP Project လုပ်နေတဲ့ R & D ကနေ ntp-4.2.8p4 ကို ထုတ်ပေးထားပါတယ်။
အပေါ်က လုံခြုံရေးပိုင်းအားနည်းချက်တွေကို ပြင်ဆင်ပေးထားပါတယ်။ အမြန်ဆုံးသာ update ဖို့ထပ်တိုက်တွန်းပါတယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

If you willing to seek System or Network job in Singapore

စင်ကာပူမှာ System or Network နဲ့ အိုင်တီ အလုပ်ရှာမယ်ဆိုရင်

Chat ကနေ လာလာပြီး မေးကြတဲ့ မေးခွန်းတခုပါ။

နည်းနည်းပွားပါရစေ။

စင်ကာပူမှာ အိုင်တီအလုပ်တွေရှိပါတယ်။ ဒီအထဲက မှ ကျတော် လုပ်ခဲ့တဲ့ လုပ်နေဆဲ အလုပ်ထဲက ၂ မျိုးအကြောင်းပြောပါရစေ။
တခုက System Administrator/System Engineer ဖြစ်ပြီး၊ နောက်တခုက Network Administrator/Network Engineer ဖြစ်ပါတယ်။
တခြား Technician, Specialist, Programmer, Software Engineer, Developer စတာတွေ အများကြီးရှိပါသေးတယ်။

ဒီအထဲက System နဲ့ Network အလုပ်တွေအကြောင်းပြောပါမယ်။
System ဆိုရင် Windows ပိုင်းနဲ့ Unix, Linux ပိုင်း ၂ မျိုး ထပ်ကွဲပါတယ်။
Company တိုင်းလိုလိုမှာ ဒီ ၂ မျိုးလုံး ကို သုံးလေ့ရှိပါတယ်။
တခုခု ကို သေသေချာချာ ပိုင်နေပြီဆိုရင် အလုပ်ရဖို့ သေချာသလောက်ရှိပါတယ်။ Windows ပိုင်းပိုင်ရင် Company တော်တော်များများမှာ အလုပ်ရနိုင်ဖို့ အလားအလာရှိပါတယ်။ Unix,Linux ပိုင်းတွေ ကျွမ်းကျင်ရင်တော့ MNC, Data Center, ISP စတဲ့ နေရာတွေမှာ အလုပ်ရဖို့ မျှော်လင့်နိုင်ပါတယ်။

အလုပ်သဘော ပေါ်မှာ မူတည်ပြီး Physical Server တွေကို သုံးတာရှိသလို Virtualized Server (ဥပမာ VMware, Oracle, Citrix) တွေ နဲ့ သုံးတာလဲ ရှိပါတယ်။
ဘယ်လို Service တွေကို Server တွေအပေါ်မှာ သုံးလဲဆိုရင် Email တွေ, Proxy တွေ, DNS တွေ, SAP လို Application တွေ, Oracle/SQL လို Database တွေ, License Serverတွေ, Syslog Server တွေ  စသည်ဖြင့် သုံးပါတယ်။
ဒါက အကျဉ်းအနေနဲ့ ပြောတာပါ။ အကျယ်တော့ အသေးစိတ်မရေးတော့ပါဘူး။ ရေးရင်လဲ ဘယ်တော့မှ ဆုံးတော့မယ်မထင်ပါဘူး။ ဒီလောက်ဆို နားလည်မယ်လို့ထင်ပါတယ်။

Network ဆိုရင်လဲ ပုံစံ မျိုးစုံနေရာမျိုးစုံနဲ့ ရှိပါတယ်။
In-house လို့ခေါ်တဲ့ Company တခုရဲ့ Network ပိုင်းကို ထိန်းကျောင်းပေးရတာမျိုးရယ်
System Integrator (SI) လို့ခေါ်တဲ့ Customer/Client Company တွေအတွက် Professional Service ပေးတဲ့ Network သမားမျိုးရယ်
Telco/ISP တွေမှာ လုပ်ရတဲ့ Network သမားတွေရယ်ဆိုပြီး ရှိပါတယ်။

In-house မှာဆိုရင် Company ပေါ်မူတည်ပြီး လုပ်ရတဲ့ နယ်ပယ် အကျဉ်းအကျယ်ရှိပါသေးတယ်။
Company သေးရင် လုပ်ရတဲ့ နယ်ပယ်ကျဉ်းသလို Company ကြီးရင် လုပ်ရတဲ့ နယ်ပယ်ကြီးပါတယ်။ ဒါပေမယ့် ဒါလည်း အမြဲတမ်းတော့ မမှန်နိုင်ပါဘူး။
MNC (Multi-National Corporation) တွေမှာ ဆိုရင်တော့ တခြား နိုင်ငံက Network တွေကို ပါ ကိုင်တွယ်ရမယ် အဲဒီနိုင်ငံတွေက Network သမားတွေနဲ့ပါ အလုပ်လုပ်ရမယ်။
နောက်တခုက Vendor တွေနဲ့ လဲ တွဲ အလုပ်လုပ်ရပါမယ်။ ဒါပေမယ့် များသောအားဖြင့် Vendor အနည်းငယ်လောက်ကိုပဲ ထိတွေ့ခွင့်ရတတ်ပါတယ်။ Company တော်တော်များများရဲ့ စံအရ Vendor တခုကိုပဲ အများဆုံး အသုံးပြုလေ့ရှိတာကြောင့်ပါ။

System Integrator တွေမှာ လုပ်မယ်ဆိုရင်တော့ Migration Project တွေ၊ Implementation Project တွေ၊ Contract/Vendor Handover Project စတာတွေ လုပ်ရပါမယ်။
သေချာတာကတော့ Multi-Vendor တွေကို ကိုင်တွယ်ရမှာပဲ ဖြစ်ပါတယ်။ ဒီအတွက် Firewall ဆိုလဲ Firewall, Routing, Switching, Wireless စတာတွေကို Technology ပိုင်းသေချာနားလည်နေမှဖြစ်မှာပါ။ ဒါမှ ဘယ် Vendor မဆို User/Admin Guide လောက်ဖတ်တာနဲ့ ကိုင်တွယ်နိုင်မှာဖြစ်ပါတယ်။

Telco/ISP တွေမှာ ဆိုရင်တော့ ကျတော် သိပ်မသိပါဘူး။ လုပ်ဖူးတာလေးတွေ ပြောရမယ်ဆိုရင်တော့ Exchange , Core Network, Network Operating Center, Front End , Backend စတဲ့နေရာတွေမှာ လုပ်ရလေ့ရှိပါတယ်။
သူကတော့ သူ့နေရာနဲ့ သူ Level တွေ သေချာ ခွဲထားတဲ့အတွက် လုပ်ရတဲ့ နေရာပေါ် မူတည်ပြီး Skill လိုအပ်ချက် အနည်းအများ ကွာပါတယ်။

တကယ်တော့ သေသေချာချာ အသေးစိတ်ရေးပြချင်ပါတယ်။ မပေးနိုင်တဲ့ အချိန်ကြောင့်ပေါ့ဗျာ။

ဒီတော့ စင်ကာပူမှာ System/Network နဲ့ အလုပ်ရှာမယ်ဆိုရင် ယေဘုယအားဖြင့် ဘာတွေ လိုအပ်တတ်လဲ ဆိုတာ သိချင်ရင် အောက်က Website ၂ ခုမှာ System Administrator, System Engineer, Network Administrator, Network Engineer ဆိုပြီး ရှာကြည့်ပါ။
Job Scope နဲ့ Requirement တွေမှာ ကိုယ်သိတာတွေ ပါသလို မသိသေးတာတွေလဲ ပါနေတာကို တွေ့ရပါလိမ့်မယ်။
လိုတာတွေ အားလုံးတော့ မသိနိုင်ပါဘူး။ သိရင်လဲ စင်ကာပူတောင် လုပ်အလုပ်လုပ်ဖို့ မလိုလောက်တော့တဲ့ အလုပ်နဲ့ ဝင်ငွေရနေလောက်ပါပြီ။
အဲဒီတော့ လိုတာတွေ ဖြည့်ပြီး (အားလုံးတော့ လဲ ဘယ်သိနိုင်ပါ့မလဲ) စင်ကာပူကို အလုပ်လာရှာပေါ့ဗျာ။

http://www.jobstreet.com.sg/
http://www.monster.com.sg/

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

How to stop "Wireless SSID" from broadcasting in Ruckus ZoneDirector and remove from APs

Ruckus Zone Director နဲ့ Access Point တွေမှာ Broadcast လုပ်ထားတဲ့ Wireless SSID ကို အကြောင်းတခုခုကြောင့်  ပြန်ပြီး disable လုပ်ဖို့လိုလာပြီဆိုရင်
ဒီနည်းလမ်းအတိုင်းလုပ်ပါ။

- ZoneDirector ကို Login ဝင်ပါ။
- Configure ကနေ WLANs ကို သွားပါ။
- WLAN Groups ကိုရှာပါ။
- System Default Group အတိုင်းပဲ သုံးထားရင် Default Group ကိုပဲ Edit လုပ်ပြီး disable လုပ်ချင်တဲ့ Wireless SSID ကို uncheck လုပ်ပြီး OK လုပ်ပါ။
- Custom Group ဆိုလဲ Custom Group ကို Edit လုပ်ပြီး disable လုပ်ချင်တဲ့ Wireless SSID ကို uncheck လုပ်ပြီး OK လုပ်ပါ။

ဒါဆိုရင် SSID disable လုပ်ခြင်းပြီးပါပြီ။
Dashboard ရဲ့ Most Recent System Activities အောက်မှာ disable လုပ်လိုက်တဲ့ SSID ကို AP တွေကနေ remove လုပ်လိုက်ပြီဆိုတဲ့ message ကိုတွေ့ရမှာ ဖြစ်ပါတယ်။

ဒါပါပဲ။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Troubleshooting unable to PING issue on Cisco RV215W

မနေ့က Meg@POP router တလုံးSite Office မှာတပ်ရတယ်။
Configuration က ရိုးရိုးလေးပါပဲ။ WAN, LAN နဲ့ Static Route ပဲ configure လုပ်ရတာပါ။
အားလုံးပြီးတော့ Router, Client ဖက်ကနေ SingTel ဖက်နဲ့ HQ ဖက်ကို Ping လို့ရတယ်။
SingTel ဖက်နဲ့ HQ ဖက်က Ping လို့ မရဘူး။

Configuration တွေကို ထပ်တလဲလဲ ပြန်စစ်တော့လဲ ဘာမှ အမှားအယွင်းမရှိပါဘူး။

နောက်ဆုံးကျတော့မှ ဒီ Cisco Router က Firewall ပါတဲ့အတွက် Security Setting တွေကို ပြန်စစ်ပါတယ်။
အဲဒီတော့မှပဲ Block WAN Request ဆိုတဲ့ Checkbox ကို တွေ့ပါတယ်။ Uncheck and Save လုပ်ပြီး ပြန်စမ်းတော့မှ Bi-directional Ping ရပါတော့တယ်။

ကဲ... ဒါမျိုး Cisco Router တွေ Configure လုပ်မယ်ဆိုရင် သတိထားရမယ့် ဟာလေးပေါ့ဗျာ။
ပြဿနာဖြစ်တဲ့ Router အမျိုးအစားက Cisco RV215W Wireless VPN Router ပါဗျာ။




ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Best practices for SonicWall VPN Tunnel configuration

Site to Site VPN Tunnel တွေ Configure လုပ်တဲ့ အခါ သတိထားရမယ့် အချက်လေးတွေရှိပါတယ်။
တကယ်လို့ ဒီအချက်လေးတွေကို သတိမထားပဲ Configure လုပ်မိတဲ့အခါ...
Remote Desktop လို... connection sensitive ဖြစ်တဲ့ application တွေ connection drop ဖြစ်ဖြစ်သွားတာမျိုးကို ကြုံရမှာ ပဲ ဖြစ်ပါတယ်။
သတိထားရမယ့် အချက်တွေကတော့ ဒါတွေပါပဲ။

၁) TCP Timeout
SonicWall Firewall အပါအဝင် Firewall အတော်များများရဲ့ Default TCP Connection Inactivity Timeout ဟာ 15 minutes ပဲ ထားတတ်ကြပါတယ်။
တကယ့်လက်တွေ့ မှာတော့ ဒီ Value ဟာ Remote Desktop အပါအဝင် Application အချို့ ကို Connection drop ဖြစ်ဖြစ်သွားစေပါတယ်။
ဒါကြောင့် အနည်းဆုံး အနေနဲ့ 30 minutes ကနေ 60 minutes အထိ ပြောင်းလဲသတ်မှတ်ပေးဖို့ Recommend လုပ်ကြပါတယ်။
TCP Timeout Value များများထားခြင်းကနေလည်း မလိုလားအပ်တဲ့ Security ပိုင်းဆိုင်ရာ ပြဿနာတွေကို ဖိတ်ခေါ်နေသလိုဖြစ်ပါတယ်။
ဒါကြောင့် Policy-based VPN Tunnels မှာပဲ ဖြစ်ဖြစ် Route-based VPN မှာပဲ ဖြစ်ဖြစ် သက်ဆိုင်ရာ Application တွေအတွက်ပဲ Allow လုပ်သင့်ပါတယ်။

၂) Packet Fragmentation
RDS လို streaming protocol တွေအတွက် packet fragmentation ပြုလုပ်ခြင်းကို ရှောင်ရှားသင့်ပါတယ်။
SonicWall အပါအဝင် Firewall များမှာ Fragmented Packet Handling နဲ့ Ignore DF (Don't Fragment) Bit ဆိုတဲ့ options ၂ ခု ပါပါတယ်။
Fragmented Packet Handling option ကို enable လုပ်ပြီး Ignore DF (Don't Fragment) Bit option ကို disable လုပ်ဖို့ recommend လုပ်ပါတယ်။

၃) Path Maximum Transmission Unit (Path MTU or PMTU)
Packet Fragmentation နဲ့ အတူတွဲပြီး သိဖို့လိုတာကတော့ Maximum Transmission Unit ဆိုတာပါပဲ။
RDS , RDP လို Streaming Protocol တွေ connection timeout ဖြစ်ရတဲ့ အကြောင်းရင်းတွေထဲက တချက်ကတော့ Maximum Transmission Unit configuration မှားတဲ့ အတွက် Packet Fragmentation ဖြစ်ပါတယ်။ ဒါကြောင့်ပဲ Connection Time out ဖြစ်စေတာပါ။
Network Device တော်တော်များများရဲ့ MTU setting က 1500 Bytes ပါ။ Cryptographic overhead အတွက် 56 Bytes နဲ့ TCP,UDP or IP စတဲ့ protocol တွေအတွက် header size ကို နှုတ်ပြီး ကျန်တဲ့ packet size ကို MTU အနေနဲ့ သတ်မှတ်ပေးဖို့လိုပါတယ်။
ကိုယ့် network/host ရဲ့ MTU ကို သိချင်ရင်တော့ ဒီ Article မှာ ရှင်းပြထားတာလေးသွားဖတ်ပါ။ ကျတော် စာရေးရတာ ပျင်းလို့ပါ။ :D
host ရဲ့ MTU ကို ပြောင်းချင်တယ်ဆိုရင်တော့  ဒီ Article မှာ ရှင်းပြထားတာလေးသွားဖတ်ပါ။

၄) Bandwidth Management
Streaming Protocol တွေ ဟာ Bandwidth ကို တောင့်တကြပါတယ်။
ဒီအတွက် Real Time Bandwidth Management Rule တွေကို သက်ဆိုင်ရာ end to end connection အတွက် configure လုပ်ဖို့လိုပါတယ်။

၅) Security Services
Security Service တွေဖြစ်တဲ့ Gateway Anti-Virus, Anti-Spyware, Intrustion Prevention Service တွေရဲ့ packet တွေကို scan လုပ်ခြင်းကြောင့်လဲ latency ကို အနည်းငယ်မြင့်သွားစေပါတယ်။
end to end connection လုပ်မယ့် host တွေဟာ အများအားဖြင့် စိတ်ချရမှု က သာမန် host တွေထက် ပိုလေ့ရှိပါတယ်။
ဒါကြောင့် end to end host တွေကို end point security မြှင့်ပေးပြီး Firewall Level မှာတော့ Security Services တွေကို bypass လုပ်ဖို့ Recommend လုပ်ကြပါတယ်။

ကဲ...ဒီအချက် ၅ ချက်ကတော့ SonicWall နဲ့ VPN Tunnel ဆောက်တဲ့အခါ စဉ်းစားရမယ့် အချက်တွေပဲ ဖြစ်ပါတယ်။
တခြား Brand တွေအတွက်လဲ အားလုံး မတူညီနိုင်ပေမယ့် အချက်တော်တော်များများက တော့ တူညီပါတယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Configuring IPS functions in HP MSR Series Router

ပြီးခဲ့တဲ့ ပို့စ်မှာ Network Attack တွေအကြောင်း အကျဉ်းရေးခဲ့ပြီးပါပြီ။
အခုကတော့ Customer Edge Router တခုဖြစ်တဲ့ HP MSR Series Router တလုံးပေါ်မှာ ဒီ Attack တွေကို ကာကွယ်ဖို့ IPS function တွေ enable လုပ်ပုံကို ရေးပါမယ်။

ပုံမှန်ဆိုရင် Customer Edge Router တွေကို ISP က Engineer/Technician က လာတပ်ပေးပြီး Configure လုပ်ပေးတာပါ။
ဒီအတွက် ပိုက်ဆံပေးရပါတယ်။ သူတို့တွေက IPS function ကို configure လုပ်မပေးသွားတာ များပါတယ်။

ပိုက်ဆံ ပိုမပေးချင်လို့ရှိရင် ကိုယ်တိုင် Configure လုပ်ရတာပေါ့။

ဘာကြောင့်ပဲ ဖြစ်ဖြစ် IPS function ကို enable လုပ်ကို လုပ်ရမှာပါ။
ဘာလို့လဲ ဆိုတော့ ကိုယ့် IP ကို Attacker တွေက တနည်းမဟုတ် တနည်းနဲ့ သိရှိတိုက်ခိုက်နိုင်တာမို့လို့ပါပဲ။

ကဲ ပြောနေတာကြာပါတယ်။ စ လိုက်ရအောင်။
- ပထမဆုံး Attack Defense Policy ကို configure လုပ်ရပါတယ်။
- ပြီးမှ Policy ကို Interface မှာ Apply လုပ်ရပါတယ်။

Single-Packet Attack တွေကို ကာကွယ်ဖို့ အောက်ပါ command တွေကို သုံးပါ။
system-view
attack-defense policy 1
signature-detect fraggle enable
signature-detect icmp-redirect enable
signature-detect large-icmp enable
signature-detect route-record enable
signature-detect smurf enable
signature-detect source-route enable
signature-detect tcp-flag enable
signature tracert enable
signature winnuke enable
signature-detect large-icmp max-length 2000 (ဒီနေရာကတော့ မိမိစိတ်ကြိုက် value ပေးနိုင်ပါတယ်။ Default အတိုင်းထားလဲရပါတယ်။)
signature-detect action drop-packet

Scanning Attack ကို ကာကွယ်ဖို့ အောက်ပါ command တွေကို သုံးပါ။
system-view
attack-defense policy 1
defense scan enable
defense scan max-rate 2000 (ဒီနေရာကတော့ မိမိစိတ်ကြိုက် value ပေးနိုင်ပါတယ်။ Default အတိုင်းထားလဲရပါတယ်။)
defense scan add-to-blacklist
defense scan blacklist-timeout 10
quit
blacklist enable

Flood-Attack တွေကို ကာကွယ်ဖို့ အောက်ပါ command တွေကို သုံးပါ။
Flood Attack တွေကို အများအားဖြင့် LAN/DMZ side တွေမှာ Server တွေကို ကာကွယ်ဖို့ သုံးပါတယ်။
system-view
attack-defense policy 1
defense syn-flood enable
defense syn-flood rate-threshold high 1000 low 750 (ဒီနေရာကတော့ မိမိစိတ်ကြိုက် value ပေးနိုင်ပါတယ်။ Default အတိုင်း high 1000 low 750 ထားလဲရပါတယ်။)
defense syn-flood ip x.x.x.x rate-threshold high xxxx low xxx (ဒီနေရာမှာတော့ IP , rate တွေကို မိမိစိတ်ကြိုက် customize လုပ်လို့ရပါသေးတယ်။ မလုပ်ချင်လဲ Default အတိုင်းထားလို့ရပါတယ်။)
defense sync-flood action drop-packet

system-view
attack-defense policy 1
defense icmp-flood enable
defense icmp-flood rate-threshold high 1000 low 750 (ဒီနေရာကတော့ မိမိစိတ်ကြိုက် value ပေးနိုင်ပါတယ်။ Default အတိုင်း high 1000 low 750 ထားလဲရပါတယ်။)
defense icmp-flood ip x.x.x.x rate-threshold high xxxx low xxx (ဒီနေရာမှာတော့ IP , rate တွေကို မိမိစိတ်ကြိုက် customize လုပ်လို့ရပါသေးတယ်။ မလုပ်ချင်လဲ Default အတိုင်းထားလို့ရပါတယ်။)
defense icmp-flood action drop-packet

system-view
attack-defense policy 1
defense udp-flood enable
defense udp-flood rate-threshold high 1000 low 750 (ဒီနေရာကတော့ မိမိစိတ်ကြိုက် value ပေးနိုင်ပါတယ်။ Default အတိုင်း high 1000 low 750 ထားလဲရပါတယ်။)
defense udp-flood ip x.x.x.x rate-threshold high xxxx low xxx (ဒီနေရာမှာတော့ IP , rate တွေကို မိမိစိတ်ကြိုက် customize လုပ်လို့ရပါသေးတယ်။ မလုပ်ချင်လဲ Default အတိုင်းထားလို့ရပါတယ်။)
defense udp-flood action drop-packet

Policy configuration ပြီးပြီဆိုရင် WAN , LAN Interface တွေမှာ Apply လုပ်ဖို့ အောက်ပါ command တွေကို သုံးပါ။
system-view
interface gi0/0
attack-defense apply policy 1
interface gi0/1
attack-defense apply policy 1

ကဲ ဒါဆိုရင် IPS function enable လုပ်လို့ပြီးပါပြီ။ Configuration ကို save ဖို့မမေ့ပါနဲ့။
ဒီလိုလုပ်ခြင်းအားဖြင့် Router ရဲ့ performance ကို အနည်းငယ်ကျဆင်းစေပါတယ်။ ဒါပေမယ့် attack ကြောင့် ဖြစ်လာမယ့် အကျိုးဆက်တွေကိုတော့ ကာကွယ်ပြီးသားဖြစ်စေတာပေါ့။

ကျတော် သုံးထားတာကတော့ HP MSR 930 Router ပဲ ဖြစ်ပါတယ်ဗျာ။
Cisco Router လို တခြား Router တွေမှာလဲ ဒါမျိုးတွေကို configure လုပ်နိုင်ပါတယ်။ တချို့အတွက်တော့ license လိုကောင်းလိုပါလိမ့်မယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Network Attack Types in brief explanation

Network Attack တွေကို အကျဉ်းအားဖြင့် Single-Packet Attack, Scanning Attack နဲ့ Flood Attack ဆိုပြီး ၃ ပိုင်း ခွဲထားပါတယ်။

Single-Packet Attack ကို Malformed Packet Attack လို့လဲ ခေါ်ပါသေးတယ်။
အကျဉ်းချုပ်အနေနဲ့ပြောရမယ်ဆိုရင် ပုံမှန်မဟုတ်တဲ့ IP packet တွေ ၊ IP fragment တွေ overlap ဖြစ်အောင်လုပ်ထားတဲ့ packet တွေ၊ illegal TCP flag packet တွေပို့လွှတ်ပြီး တိုက်ခိုက်တာကို ပြောတာပါ။
ဒီပုံစံတိုက်ခိုက်မှုမျိုးကို ပစ်မှတ်ထားတဲ့ System malfunction သို့မဟုတ် crash ဖြစ်သွားစေတာမျိုး၊ network bandwidth ကို အများကြီး ယူသုံးပစ်ပြီး လေးသွားအောင် လုပ်ပစ်တာမျိုးတွေမှာ တွေ့ရလေ့ရှိပါတယ်။
Single-Packet Attack ပုံစံမျိုးစုံရှိပါတယ်။ အောက်က attack type တွေကတော့ Single-Packet Attack type အမျိုးအစားတွေပဲ ဖြစ်ပါတယ်။
Smurf attack
ICMP redirect attack
ICMP unreachable attack
Large ICMP attack
TCP flag attack
Tracert attack
Fraggle attack
WinNuke attack
Land attack
Source route attack
Route record attack

Scanning Attack ကတော့ attack ဆိုတာထက် nmap, nessus, satan, ettercap  တို့လို scanning tool တွေသုံးပြီး တိုက်ခိုက်မယ့် ပစ်မှတ််ရဲ့ network topology၊ host address တွေနဲ့ host တွေမှာ run ထားတဲ့ service နဲ့ port တွေကို
Scan လုပ်တာပါ။ ရလာတဲ့ Scan result ပေါ်မှာ အခြေခံပြီးတော့မှ ဘယ်နေရာမှာ အားနည်းချက်ရှိတယ် ဘာကို တိုက်ခိုက်မယ် ဆိုတာကို ဆုံးဖြတ်တာပါ။
သူကလဲ Active နဲ့ Passive Scanning ဆိုပြီး ၂ ခု ရှိတယ်ဗျ။
အောက်က attack type ကတော့ တခုတည်းသော scanning attack အမျိုးအစားပဲ ဖြစ်ပါတယ်။
Scan attack

Flood Attack ဆိုတာကတော့ လွယ်လွယ်ပြောရရင် service ပေးနေတဲ့ device ကနေ ပုံမှန်မဟုတ်တဲ့ service request တွေကို အလွန်များပြားစွာ ပို့လွှတ်ပြီး service host ကို busy ဖြစ်စေ၊ service interruption ဖြစ်စေတာပါ။
တနည်းအားဖြင့် Denial of Services ပေါ့ဗျာ။
အောက်က attack type တွေကတော့ Flood Attack တွေပေါ့ဗျာ။
ICMP flood attack
UDP flood attack
SYN flood attack

ကဲ ဒီလောက်ဆိုရင် Network Attack Type တွေ အကြောင်းကို အကျဉ်းအားဖြင့် သိပြီလို ယူဆပါတယ်။
တကယ်တော့ Attack တွေအကြောင်းပြောမယ်ဆိုရင် ကျယ်ပြန့်လွန်းလှပါတယ် ဒီထက်မကတဲ့ Operating Attacks, Scripted Attacks, Misconfiguration Attacks စတာတွေလဲ ရှိပါသေးတယ်။
ဒီပို့စ်ကိုရေးရတာကတော့ နောက်ရေးမယ့် HP MSR Router ကို သုံးပြီး IPS function ကို enable လုပ်ပြီး attack prevention လုပ်ပုံရေးချင်လို့ပါ။
နောက် ပို့စ် မှာ ဒီ Attack တွေကို HP MSR Router ကို သုံးပြီး ဘယ်လို prevent လုပ်မလဲ ဆိုတာ ရေးပါမယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Configuring NTP Server in HP Procurve Switches

Log  တွေကို စစ်ဆေးတဲ့အခါ အချိန်တိကျနေဖို့လိုပါတယ်။
ဒီတခါတော့ Cisco မဟုတ်တဲ့ HP Switch တွေမှာ NTP Server Configure လုပ်ပုံလေး ြပန်ဝေမျှချင်ပါတယ်။
HP Procurve Switch တွေဟာ NTP အစား less secure ြဖစ်တဲ့ SNTP ကိုပဲ သုံးလို့ရပါတယ်။

Configure လုပ်ကြည့်ရအောင်ဗျာ

Switch ထဲကို Login ဝင်ပါ။ ြပီးရင်အောက်က command လေးတွေရိုက်ထည့်ပါ။
configure terminal
timesync sntp


sntp unicast (NTP Server တခုထဲကိုပဲ သုံးချင်တယ်ဆိုရင် unicast ပေါ့)
(or)
sntp broadcast (တခုထက်ပိုတဲ့ NTP Server သုံးချင်ရင်တော့ broadcast ပေါ့ဗျာ)

sntp server priority 1 218.186.3.36
(or)
sntp server  218.186.3.36

(ဒီ command ၂ ခု ကတော့ switch model ပေါ်မူတည်ြပီးကွဲသွားတာပါ။
 တချို့ switch တွေက priority command ထည့်ပေးဖို့လို ြပီး တချို့ switch တွေက မလိုပါဘူး။
ntp server ၃ ခုထက်ပိုထည့်လို့မရတာကိုလဲ သိထားပါ။ ကျတော်ကတော့ စင်ကာပူ အတွက် ntp server IP ကိုထည့်ထားပါတယ်။)

time timezone +480 (ဒီနေရာမှာ +480 ဆိုတာ စင်ကာပူအချိန်ကို မိနစ်နဲ့တွက်ြပီးပြောင်းထားတာပါ။ မိမိဒေသစံတော်ချိန်နဲ့တူအောင်တွက်ထည့်ဖို့လိုပါတယ်။
တွက်ပုံကတော့ GMT+Regional Time in Minutes ပါ။ စင်ကာပူဆိုရင် GMT+8 ပါ။ 8 နာရီကို မိနစ်ပြောင်းတော့ ၄၈၀ ရပါတယ်။)

အပေါ်က command တွေအားလုံး ရိုက်ထည့်ြပီး Configure လုပ်ြပီးပြီဆိုရင်

show sntp
show sntp statistics
(ဒီ command က တချို့ switch model တွေမှာ အလုပ်မလုပ်ပါဘူး။)

စတဲ့ command တွေသုံးပြီး NTP Server setting အလုပ် လုပ်လား မလုပ်လား ဆိုတာကို စစ်ပါ။
show time ဆိုတဲ့ Command လေးနဲ့ပါ အချိန် မှန်မမှန် စစ်လိုက်ပါအုံး။

အလုပ်လုပ်တယ်ဆိုရင် Write Memory command နဲ့ Configuration ကို save ြပီး Terminal/console session ကနေ logout ပေါ့ဗျာ။
အလုပ်မလုပ်ရင်တော့ အပေါ်က command တွေအတိုင်း ြပန်စစ်ပေါ့။

ဒီလောက်ဆို အဆင်ပြေမယ်ထင်ပါတယ်။

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable,pass it on then)


Resetting admin login password for GMS Application Interface of SonicWall GMS Virtual Appliance on UMA

ကိုယ့် Network မှာ SonicWall Firewall တွေ အများကြီးရှိတယ်ဆိုရင်တော့ SonicWall GMS မရှိပဲ Manage လုပ်ဖို့ တော်တော်မလွယ်ပါဘူး။
GMS မှာ login ၂ ခု ရှိပါတယ်။ System Interface Login နဲ့ Application Interface Login ဆိုပြီးတော့ပါ။

System Interface ကတော့ Hardware/Virtual Appliance GMS ကို manage လုပ်ဖို့ပါ။ Application Interface ကတော့ GMS နဲ့ control လုပ်ထားတဲ့ Device တွေကို manage လုပ်ဖို့ပါ။
တကယ်လို့ System Interface Login Password ကိုမေ့သွားတယ် ဆိုရင်တော့ Dell SonicWall Technical Support ကိုဆက်သွယ်ပေတော့ဗျ။ သူတို့ပဲ reset လုပ်ပေးနိုင်လို့ပါ။
Support Contract/License ကလဲ Expire ဖြစ်နေတယ်။ Renew လဲ လုပ်မထားဖူးဆိုရင်တော့ အစအဆုံး ပြန် Install လုပ်ပေတော့ပဲ။ ဒီတော့ ဒီ password ကိုတော့ မမေ့ပစ်နဲ့ပေါ့ဗျာ။

Application Interface login password ကို reset လုပ်ဖို့ကတော့ အောက်ကအဆင့်အတိုင်းသာလိုက်လုပ်ပါ။ 
Password မေ့လို့ မှားနေရင် အောက်ကလို ပေါ်ပါမယ်။

Password reset လုပ်ဖို့ MySQL Query Browser ဆိုတာလိုပါတယ်။ သူက GMS Database ကို ဝင်ဖို့ပါ။

၁။ အောက်က လင့်မှာ သွား  Download လုပ်ပြီး GMS နဲ့ Subnet တူတဲ့ Server/PC ပေါ်ကနေပဲဖြစ်ဖြစ်၊ GMS ကို access လုပ်လို့ရတဲ့ PC မှာ တင်ပြီး သူ့ကို run ပါ။

၂။ MySQL Query Browser ကိုဖွင့်ပါ။

၃။ GMS Database ကို access right ရတဲ့ account သို့မဟုတ်  'root' account ကိုသုံးပြီး အောက်ကပုံမှာ ပြထားသလို login ဝင်ပါ။

၄။ အောက်က command သုံးကြောင်းကို ပုံမှာပြထားသလို ရိုက်ထည့်ပြီး 'Execute' button ကိုနှိပ်ပါ။ Successful ဖြစ်ရင် တတိယမြောက်ပုံအတိုင်း မြင်ရပါမယ်။

UPDATE USERS 
SET PASSWORD = ‘5f4dcc3b5aa765d61d8327deb882cf99’
WHERE ID = ‘admin’;




၅။  Password reset successful ဖြစ်ပြီဆိုတာနဲ့ GMS Application Interface ကို အောက်ကပုံအတိုင်း Login ပြန်ဝင်ကြည့်ပါ။ Reset လုပ်လိုက်တဲ့ အခါ default password က password ပါ။

  
 ဒီ ပို့စ်အတွက် ကျတော်စမ်းပြထားတဲ့ GMS Virtual Appliance Version က GMS 7.2 ပဲဖြစ်ပါတယ်။
ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Anger EK is exploiting Adobe Flash Vulnerability (CVE-2015-5560)

Adobe Flash Player 18.0.0.209 နှင့် အရင်ဗားရှင်း တွေမှာ Integer Overflow Vulnerability တခုကို Security Research Team တွေက မနေ့ကတွေ့ထားပါတယ်

သူ့ပုံစံက Adobe Flash Player ဟာ ပုံမှန်မဟုတ်တဲ့ MP3 file ကို load လုပ်ပြီး  Data Size ကြီးကြီးတွေကူးစေကာ small buffer ကို over flow ဖြစ်စေတာပါ

ဒီအားနည်းချက်ကို အသုံးချ ပြီးတော့မှ Anger Exploit Kit ဆိုတာနဲ့ Exploit လုပ်ဖို့ကြိုးစားတော့တာပါ

ဒီအားနည်းချက်က 64bit platform တွေမှာ ပဲ သက်ရောက်မှု ရှိပါတယ်

အသေးစိတ် သိချင်ရင်တော့ CVE-2015-5560  
ဆိုတာကို ဖတ်ပါ

ပျော်ရွှင်ပါစေဗျာ
(Be knowledgeable, pass it on then)

How to deploy 2.4GHz Wireless properly?

2.4GHz Wireless ကို Deploy လုပ်တော့မယ်ဆိုရင် သတိထားစရာ အတော်များများရှိပါတယ်။

Channel ရွေးချယ်မှု မှားယွင်းပြီဆိုတာနဲ့ Wireless Network ရဲ့ Stability , Performance တွေ သိသိသာသာ ကို ကျဆင်းနေစေမှာပဲ ဖြစ်ပါတယ်။

2.4GHz အတွက် ရနိုင်တဲ့ Channel တွေက တချို့ မှာဆို 1 to 11 , တချို့မှာတော့ 1 to 13 ထိရှိပါတယ်။

ဒီ Channel ထဲက Overlap မဖြစ်တဲ့ Channel ငါးခုပဲ ရှိပါတယ်။
Channel 1 to 11 ထိ ရနိုင်တဲ့ Wireless Devices တွေမှာ Channel 1,6 နဲ့ 11 တွေက Overlap မဖြစ်ပါဘူး။
Channel 1 to 13 ထိ ရနိုင်တဲ့ Wireless Devices တွေမှာ Channel 1,5,9 နဲ့ 13 တွေက Overlap မဖြစ်ပါဘူး။

Wireless Device တော်တော်များများဟာ ဒီ Channel 1 to 13 ထဲက တခုခုကို ပါဝါစဖွင့်ထဲက အလိုအလျောက်ရွေးချယ်ပါတယ်။

Standalone or Controller Base Wireless Device တွေအတွက် Channel ကို Auto Select လုပ်စေတာဟာ နေရာတိုင်းအတွက် မှန်ကန်တဲ့ နည်းလမ်းမဟုတ်ပါဘူး။

မိမိ နေရာဝန်းကျင်မှာ အလားတူ Wireless Device တွေရှိလာပြီဆိုရင် တည်ငြိမ်ပြီး လုပ်ဆောင်နိုင်စွမ်းကောင်းတဲ့ Wireless Network Area တခု ဘယ်လိုမှ မရနိုင်တော့ပါဘူး။

ဘာဖြစ်လို့ မရနိုင်တာလဲ ဆိုတော့ အောက်ပါ အချက်တွေကြောင့်ပါပဲ။

၁) Co-Channel Interference
တူညီတဲ့ Channel တခုထဲ မှာ Wi-Fi Devices တွေများလာပြီဆိုရင် Half-Duplex နဲ့ အလုပ်လုပ်တဲ့ Wireless Device တွေအတွက် ကြီးမားတဲ့ အနှောက်အယှက်ကိုဖြစ်စေပါတယ်။

၂) Adjacent-Channel Interference
မိမိ Wireless Network Area အတွင်းနဲ့ အနီးတဝိုက်မှာ အခြား Wireless Boradcast Device တွေရှိနေပြီး အားလုံးက Auto Channelization နဲ့ အလုပ်လုပ်နေတာကလဲ မိမိ Wireless Network ကို အကြီးအကျယ် အနှောက်အယှက်ဖြစ်စေပါတယ်။

၃) Non-Wi-Fi Interference
Analog Camera, CCTV, Cordless Phone , Microwave Oven စတဲ့ ပစ္စည်းတွေရဲ့ Frequency ဟာလည်း 2.4GHz ကိုပဲ သုံးထားတာပါ။
ဒါကြောင့် မိမိ Wireless Network Area အတွင်းနဲ့ အနီးတဝိုက်မှာ ဒါမျိုး ပစ္စည်းတွေရှိတယ်ဆိုရင်တော့ Interference ကို မလွှဲမသွေ ကြုံတွေ့ရမှာပါ။

ဒီတော့ မိမိ Wireless Network အတွက် အကောင်းဆုံး ဖြစ်အောင် Channel ရွေးဖို့လိုပါတယ်။
အောက်ကပုံကိုကြည့်ပါ။ inSSIDer Home ဆိုတဲ့ Application ကိုသုံးပြီး Wireless Network တွေကို Scan လုပ်ထားတာပါ။



ပုံပါအတိုင်းဆို လက်ရှိ Channel 1 မှာ အလုပ်လုပ်နေတဲ့ SINGTEL-931_EXT ဆိုတဲ့ Wireless ကို Channel 11 ကို ပြောင်းပစ်ဖို့ အသင့်ဆုံးပါ။

ဒါက Standalone Device အတွက်အကောင်းဆုံးပါပဲ။
တကယ်လို့ Controller Base Wireless Device တွေ အတွက်ဆိုလဲ ဒီလိုပဲ ရွေးချယ်ရမှာပါ။
တခုထက်ပိုတဲ့ AP or Wireless Router တွေနဲ့ တခုထက်ပိုတဲ့ SSID တွေသုံးထားရင်တော့ Channel တွေအများကြီးထဲက 1,6,11 or 1,6,9,13 တွေကိုရွေးပြီး Balance ညီအောင်ထားပေးဖို့လိုပါလိမ့်မယ်။

ဒါကြောင့် Auto Channelization , Auto Channel Width တွေဟာ နေရာတိုင်းမှာ အမြဲတမ်း မှန်ကန်စွာ အလုပ်မလုပ်နိုင်ဘူးဆိုတာ သိထားသင့်ပါတယ်။
လိုအပ်သလို Manually Adjust လုပ်ပေးဖို့လိုပါတယ်။ ဒီလိုလုပ်ဖို့လဲ အင်တာနက်မှာ အသင့်သုံးနိုင်တဲ့ Wireless Channel Scanner Free Application တွေရှိပါတယ်။

Wireless Network အကြောင်း အတွေ့အကြံုတွေ ဆက်ရေးပါအုံးမယ်။ မကြာမီ လာမည် မျှော်... :D

ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

OpenSSL X509_cmp_time DoS

Time နဲ့ ပတ်သက်ပြီး OpenSSL Certificate တွေမှာ လုံခြုံရေး အားနည်းချက် တခု ကို လုံခြုံရေးသုတေသီ များက မကြာသေးခင်က ရှာဖွေတွေ့ ရှိထားပါတယ်

ယင်းအားနည်းချက်မှ DoS Attack ဖြင့်တိုက်ခိုက်နိုင်တယ်လို့ ဆိုပါတယ်

အသေးစိပ် သိချင်ရင်တော့ CVE ID 2015 https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-1789 ဆိုတာကိုဖတ်ပါ

မိမိ Device များကို patch လုပ်ပါ

ပျော်ရွှင်ပါစေဗျာ
(Be knowledgeable, pass it on then)

Microsoft Security Bulletin Coverage (August 11, 2015)

ဩဂုတ်လအတွက် Security Advisories တွေကို Microsoft က ထုံးစံအတိုင်း ထုတ်ပြန်ထားပါတယ်။

အောက်က CVE ID တွေကို သင့် IPS/IDS, Firewall စတဲ့ Security Device တွေ၊ Operating System တွေနဲ့ Application တွေက prevent လုပ်နိုင်ဖို့လိုပါတယ်။

Dell SonicWall Security Device တွေကတော့ fix လုပ်ထားပြီးပါပြီတဲ့ဗျာ။

MS15-079 Cumulative Security Update fro Internet Explorer

  • CVE-2015-2423 Unsafe Command Line Parameter Passing Vulnerability
    This is a local vulnerability.
  • CVE-2015-2441 Memory Corruption Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2442 Memory Corruption Vulnerability
    IPS: 11076 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 1"
  • CVE-2015-2443 Memory Corruption Vulnerability
    IPS: 11077 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 2"
  • CVE-2015-2444 Memory Corruption Vulnerability
    IPS: 11078 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 3"
  • CVE-2015-2445 ASLR Bypass
    There are no known exploits in the wild.
  • CVE-2015-2446 Memory Corruption Vulnerability
    IPS: 11079 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 4"
  • CVE-2015-2447 Memory Corruption Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2448 Memory Corruption Vulnerability
    IPS: 11080 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 5"
  • CVE-2015-2449 ASLR Bypass
    There are no known exploits in the wild.
  • CVE-2015-2450 Memory Corruption Vulnerability
    IPS: 11081 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 6"
  • CVE-2015-2451 Memory Corruption Vulnerability
    IPS: 11083 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 8"
  • CVE-2015-2452 Memory Corruption Vulnerability
    IPS: 11082 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 7"
MS15-080 Vulnerabilities in Microsoft Graphics Component Could Allow Remote Code Execution

  • CVE-2015-2431 Microsoft Office Graphics Component Remote Code Execution Vulnerability
    SPY: 4276 "Malformed-File doc.MP.30"
  • CVE-2015-2432 OpenType Font Parsing Vulnerability
    SPY: 3148 "Malformed-File otf.MP.12"
  • CVE-2015-2433 Kernel ASLR Bypass Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2435 TrueType Font Parsing Vulnerability
    SPY: 4232 "Malformed-File ttf.MP.4"
  • CVE-2015-2453 Windows CSRSS Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2454 Windows KMD Security Feature Bypass Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2455 TrueType Font Parsing Vulnerability
    SPY: 4209 "Malformed-File ttf.MP.3"
  • CVE-2015-2456 TrueType Font Parsing Vulnerability
    SPY: 3149 " Malformed-File otf.MP.13 "
  • CVE-2015-2458 OpenType Font Parsing Vulnerability
    SPY: 3150 " Malformed-File otf.MP.14 "
  • CVE-2015-2459 OpenType Font Parsing Vulnerability
    SPY: 3151 " Malformed-File otf.MP.15 "
  • CVE-2015-2460 OpenType Font Parsing Vulnerability
    SPY: 3152 " Malformed-File otf.MP.16 "
  • CVE-2015-2461 OpenType Font Parsing Vulnerability
    SPY: 3153 " Malformed-File otf.MP.17 "
  • CVE-2015-2462 OpenType Font Parsing Vulnerability
    SPY: 3157 " Malformed-File otf.MP.20 "
  • CVE-2015-2463 TrueType Font Parsing Vulnerability
    SPY: 3155 " Malformed-File otf.MP.18 "
  • CVE-2015-2464 TrueType Font Parsing Vulnerability
    SPY: 3156 " Malformed-File otf.MP.19 "
  • CVE-2015-2465 Windows Shell Security Feature Bypass Vulnerability
    There are no known exploits in the wild.
MS15-081 Vulnerability in Microsoft Office Could Allow Remote Code Execution

  • CVE-2015-1642 Microsoft Office Memory Corruption Vulnerability
    SPY: 4366 "Malformed-File docx.MP.5"
  • CVE-2015-2423 Unsafe Command Line Parameter Passing Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2466 Microsoft Office Remote Code Execution Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2467 Microsoft Office Memory Corruption Vulnerability
    SPY: 3159 "Malformed-File doc.MP.25"
  • CVE-2015-2468 Microsoft Office Memory Corruption Vulnerability
    SPY: 3160 "Malformed-File doc.MP.26"
  • CVE-2015-2469 Microsoft Office Memory Corruption Vulnerability
    SPY: 3365 "Malformed-File doc.MP.27"
  • CVE-2015-2470 Microsoft Office Integer Underflow Vulnerability
    SPY: 4193 " Malformed-File doc.MP.28"
  • CVE-2015-2477 Microsoft Office Memory Corruption Vulnerability
    SPY: 4195 "Malformed-File doc.MP.29"
MS15-082 Vulnerabilities in RDP Could Allow Remote Code Execution 

  • CVE-2015-2472 Remote Desktop Session Host Spoofing Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2473 Remote Desktop Protocol DLL Planting Remote Code Execution Vulnerability
    There are no known exploits in the wild.
MS15-083 Vulnerabilities in Server Message Block Could Allow Remote Code Execution 

  • CVE-2015-2474 Server Message Block Memory Corruption Vulnerability
    There are no known exploits in the wild.
MS15-084 Vulnerability in XML Core Services Could Allow Elevation of Privilege 

  • CVE-2015-2434 MSXML Information Disclosure Vulnerability
    IPS: 5770 "Downgraded TLS Traffic"
  • CVE-2015-2440 MSXML Information Disclosure Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2471 MSXML Information Disclosure Vulnerability
    IPS: 5770 "Downgraded TLS Traffic"
MS15-085 Vulnerability in Mount Manager Could Allow Elevation of Privilege 

  • CVE-2015-1769 Mount Manager Elevation of Privilege Vulnerability
    This is a local vulnerability.
MS15-086 Vulnerability in System Center Operations Manager Could Allow Elevation of Privilege 

  • CVE-2015-2420 System Center Operations Manager Web Console XSS Vulnerability
    There are no known exploits in the wild.
MS15-087 Vulnerability in UDDI Services Could Allow Elevation of Privilege 

  • CVE-2015-2475 UDDI Services Could Allow Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
MS15-088 Unsafe Command Line Parameter Passing Could Allow Information Disclosure 

  • CVE-2015-2423 Unsafe Command Line Parameter Passing Vulnerability
    This is a local vulnerability.
MS15-089 Vulnerabilities in WebDAV Could Allow Information Disclosure 

  • CVE-2015-2476 WebDAV Client Information Disclosure Vulnerability
    IPS: 5770 "Downgraded TLS Traffic"
MS15-090 Vulnerability in Microsoft Windows Could Allow Elevation of Privilege 

  • CVE-2015-2428 Windows Object Manager Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2429 Windows Registry Elevation of Privilege Vulnerability
    This is a local vulnerability.
  • CVE-2015-2430 Windows Filesystem Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
MS15-091 Cumulative Security Update for Microsoft Edge 

  • CVE-2015-2441 Memory Corruption Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2442 Memory Corruption Vulnerability
    IPS: 11076 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 1"
  • CVE-2015-2446 Memory Corruption Vulnerability
    IPS: 11079 "Internet Explorer Memory Corruption Vulnerability (MS15-079) 4"
  • CVE-2015-2449 ASLR Bypass
    There are no known exploits in the wild.
MS15-092 Vulnerabilities in .NET Framework Could Allow Elevation of Privilege 

  • CVE-2015-2479 RyuJIT Optimization Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2480 RyuJIT Optimization Elevation of Privilege Vulnerability
    There are no known exploits in the wild.
  • CVE-2015-2481 RyuJIT Optimization Elevation of Privilege Vulnerability
    There are no known exploits in the wild.


ပျော်ရွှင်ပါစေဗျာ။
(Be knowledgeable, pass it on then)

Contact Form for ictformyanmar.com

Name

Email *

Message *